Hyperswitch - Payments API Service Degradation – Incident details

All systems operational

Payments API Service Degradation

Resolved
Degraded performance
Started about 1 month agoLasted about 1 hour

Affected

Production

Degraded performance from 5:01 PM to 6:24 PM, Operational from 5:01 PM to 6:24 PM

Payins API

Degraded performance from 5:01 PM to 6:24 PM

Unified Checkout

Operational from 5:01 PM to 6:24 PM

Control Center

Operational from 5:01 PM to 6:24 PM

Card Vault

Operational from 5:01 PM to 6:24 PM

Updates
  • Resolved
    Resolved

    Between March 3rd 2026 10:31 PM IST and 11:54 PM IST the Payments API in the Production Hyperswitch environment (us-east-1) experienced service degradation causing merchant payments to fail.

    The issue was mitigated at 11:54 PM IST and all services resumed regular operations.


  • Investigating
    Investigating
    We are currently investigating this incident.