Hyperswitch - Performance Degradation for Payment APIs – Incident details

All systems operational

Performance Degradation for Payment APIs

Resolved
Degraded performance
Started 23 days agoLasted about 1 hour

Affected

Production

Degraded performance from 3:38 AM to 4:46 AM

Payins API

Degraded performance from 3:38 AM to 4:46 AM

Updates
  • Resolved
    UTC
    Resolved

    The database was manually failed over to the primary instance resolving the issue.

  • Identified
    UTC
    Identified

    A database out of memory error resulted in a failover to a smaller instance affecting the success rate of Payment APIs